码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1789Doing Homework again(贪心)

时间:2014-08-01 23:12:42      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   strong   io   

题目链接:

啊哈哈,点我点我

思路:
这道题是简单的贪心。。先按分数从大到小排序,然后将这个分数的截止日期从后向前扫描,如果碰到没有被标记的则这一天可以做这个作业。。。

题目:

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6451    Accepted Submission(s): 3838


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy

代码为:
#include<cstdio>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;

map<int,bool>mp;

struct homework
{
    int deadline,score;
}home[1000+10];

bool cmp(homework a,homework b)
{
   if(a.score==b.score)
        return a.deadline<b.deadline;
   else
        return a.score>b.score;
}

int main()
{
    int n,ans,l,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&home[i].deadline);
            mp[i]=false;
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&home[i].score);
        sort(home+1,home+1+n,cmp);
        for(int i=1;i<=n;i++)
        {
            for(l=home[i].deadline;l>=1;l--)
            {
                if(!mp[l])
                {
                    mp[l]=true;
                    break;
                }
            }
            if(l<1)  ans=ans+home[i].score;
        }
        printf("%d\n",ans);
    }
    return 0;
}



hdu1789Doing Homework again(贪心),布布扣,bubuko.com

hdu1789Doing Homework again(贪心)

标签:des   style   http   color   java   os   strong   io   

原文地址:http://blog.csdn.net/u014303647/article/details/38342241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!