码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1029 --------map

时间:2014-05-07 02:08:52      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

bubuko.com,布布扣
Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 15477    Accepted Submission(s): 6296


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
 

Sample Output
3
5
1
 
bubuko.com,布布扣

我的行不通的代码:

bubuko.com,布布扣
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#define N 1000000
using namespace std;
int comp(int a,int b)
{
    return a<b;
}
 
int main()
{
    int i,n,m;
    int a[N],b[N];
    while(cin>>n)
    {
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            b[i]=1;
        }
        sort(a,a+n,comp);
        for(i=1;i<n;i++)
        {
            if(a[i]==a[i-1])
            b[i]+=b[i-1];
            else 
            continue;
        }
        for(i=0;i<n;i++)
        {
            if(b[i]==(n+1/2))
            {
                cout<<a[i]<<endl;
                break;
            }
        }
    }
    return 0;
}
bubuko.com,布布扣

数据太大这样做行不通

AC:

bubuko.com,布布扣
#include <iostream>
#include <map>
using namespace std;

int main()
{
    int n,d,ans;
    while(cin>>n)
    {
        map<int,int> m;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&d);
            m[d]++;
            if(m[d]==(n+1)/2)
                ans=d;
        }
        printf("%d\n",ans);
    }
    return 1;
}
bubuko.com,布布扣

 

HDU1029 --------map,布布扣,bubuko.com

HDU1029 --------map

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/hezixiansheng8/p/3712157.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!