码迷,mamicode.com
首页 > 其他好文 > 详细

hduoj2802F(N)

时间:2014-08-02 12:54:33      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   strong   io   

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3202    Accepted Submission(s): 1106


Problem Description
bubuko.com,布布扣
Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
1 2 3 0
 

Sample Output
1 7 20
 
知识点:鸽巢原理、递推

#include<iostream>
using namespace std;

int main()
{  int a[5000];
   a[1]=1;
   a[2]=7;
   int i,n;
   for(i=3;i<=4018;i++)
    {a[i]=a[i-2]+3*i*(i-1)+1;
      if(a[i]>2009) a[i]=a[i]%2009;}
   while(cin>>n,n)
   {
       cout<<a[n%4018]<<endl;
   }
    return 0;
}


hduoj2802F(N),布布扣,bubuko.com

hduoj2802F(N)

标签:des   style   http   color   java   os   strong   io   

原文地址:http://blog.csdn.net/hpuhjl/article/details/38346607

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!