标签:des style http color os strong io for
Bad Cowtractors
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 10634 |
|
Accepted: 4504 |
Description
Bessie has been hired to build a cheap internet network among Farmer John‘s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes
between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn‘t even want to pay Bessie.
Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that
it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of
connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output
42
Hint
OUTPUT DETAILS:
The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
Source
题意:farmer john 很吝啬,他雇了bessie不想给他钱,bessie就想让John花更多的工程钱,即使路变得最长。
思路:最大生成树。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>
using namespace std;
int n,m;
int mp[1005][1005];
int vis[1005];
int low[1005];
int prim(){
int pos,minx,res=0;
memset(vis,0,sizeof(vis));
vis[1]=1;
pos=1;
for(int i=1;i<=n;i++){
if(pos!=i)
low[i]=mp[1][i];
}
for(int i=1;i<n;i++){
minx=0;
for(int j=1;j<=n;j++){
if(!vis[j]&&minx<low[j]){
minx=low[j];
pos=j;
}
}
if(minx==0) {res=-1; break;}
res+=minx;
vis[pos]=1;
for(int j=1;j<=n;j++){
if(!vis[j]&&low[j]<mp[pos][j])
low[j]=mp[pos][j];
}
}
return res;
}
int main(){
scanf("%d%d",&n,&m);
memset(mp,-1,sizeof(mp));
for(int i=0;i<m;i++){
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(mp[a][b]<c)
mp[a][b]=mp[b][a]=c;
}
printf("%d\n",prim());
}
POJ 2377 Bad Cowtractors,布布扣,bubuko.com
POJ 2377 Bad Cowtractors
标签:des style http color os strong io for
原文地址:http://blog.csdn.net/kimi_r_17/article/details/38349235