标签:des style http color os strong io for
Six Degrees of Cowvin Bacon
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 2986 |
|
Accepted: 1390 |
Description
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".
The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one ‘degree‘ away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two ‘degrees‘ away from each other (counted as: one degree to the cow they‘ve worked with and one more to the other cow). This scales to the general case.
The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]
Source
题意:牛跟自己的分离度是0,如果两牛合作分离度则为1,如果两牛同时和第三头牛合作分离度为2.求一头牛到其他牛最小的平均分离度,即求最短路。
思路:用floyd算法求最短路,注意最后结果的一个坑 要*100。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>
using namespace std;
const int INF=1000000009;
int dis[605][605];
int a[605];
int n;
void floyd(){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
for(int k=1;k<=n;k++){
dis[j][k]=min(dis[j][k],dis[j][i]+dis[i][k]);
}
}
}
}
int main(){
int m;
scanf("%d%d",&n,&m);
memset(dis,INF,sizeof(dis));
for(int i=0;i<m;i++){
int nn;
scanf("%d",&nn);
for(int j=0;j<nn;j++){
scanf("%d",&a[j]);
}
for(int j=0;j<nn;j++){
for(int k=0;k<j;k++){
dis[a[j]][a[k]]=dis[a[k]][a[j]]=1;
}
}
}
floyd();
int ans=INF;
for(int i=1;i<=n;i++){
int sum=0;
for(int j=1;j<=n;j++){
if(i!=j)
sum+=dis[i][j];
}
ans=min(sum,ans);
}
printf("%d\n",int(ans*100/(n-1)));
return 0;
}
POJ 2139 Six Degrees of Cowvin Bacon,布布扣,bubuko.com
POJ 2139 Six Degrees of Cowvin Bacon
标签:des style http color os strong io for
原文地址:http://blog.csdn.net/kimi_r_17/article/details/38349055