码迷,mamicode.com
首页 > 其他好文 > 详细

poj3181 Dollar Dayz (DP+大数)

时间:2016-06-02 14:48:06      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

Dollar Dayz
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:

        1 @ US$3 + 1 @ US$2 
 1 @ US$3 + 2 @ US$1 
 1 @ US$2 + 3 @ US$1 
 2 @ US$2 + 1 @ US$1 
 5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5
一个DP题 不过由于数太大了。。。所以我选用的java...

其中dp数组存贮组成当前数的个数

import java.math.*;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sca =new Scanner(System.in);
		int k,n;
		while(sca.hasNext())
		{
			n=sca.nextInt();
			k=sca.nextInt();
			BigInteger dp []=new BigInteger[1005];
			for(int i=0;i<1005;i++)
				dp[i]=BigInteger.ZERO;
			dp[0]=BigInteger.ONE;
			for(int i=1;i<=k;i++){
				for(int j=0;j<=n;j++){
					if(j>=i&&dp[j-i]!=BigInteger.ZERO){
						dp[j]=dp[j].add(dp[j-i]);
					}
				}
			}
			System.out.println(dp[n]);
		}
		
	}
}



poj3181 Dollar Dayz (DP+大数)

标签:

原文地址:http://blog.csdn.net/su20145104009/article/details/51539320

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!