码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2499 Binary Tree

时间:2014-08-03 10:18:25      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   

Binary Tree
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6034   Accepted: 2801

Description

Background 
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
  • The root contains the pair (1, 1). 
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem 
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

Input

The first line contains the number of scenarios. 
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent 
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input

3
42 1
3 4
17 73

Sample Output

Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source


#include<iostream>
using namespace std;
int main()
{
    int N;
    cin>>N;

    int c;
    for(c=1;c<=N;c++)
    {
        int a,b;//节点标识
        cin>>a>>b;

        int left =0;
        int right=0;//左走的和右走的步数初始化

        while(a>1||b>1)//若未走到根
        {
            if(a>b)
            {
                int up;
                up=(a-1)/b;
                left=left+up;
                a=a-up*b;
            }
            else
            {
                int up;
                up=(b-1)/a;
                right=right+up;
                b=b-up*a;
            }
        }
        cout<<"Scenario #"<<c<<":"<<endl;
        cout<<left<<" "<<right<<endl<<endl;
    }
}










POJ 2499 Binary Tree,布布扣,bubuko.com

POJ 2499 Binary Tree

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/sunshumin/article/details/38355629

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!