码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1023 Train Problem II

时间:2016-06-06 18:51:48      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7943    Accepted Submission(s): 4261


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

 

Sample Input
1 2 3 10
 

 

Sample Output
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 

 

Author
Ignatius.L
 
技术分享
#include <stdio.h>
#include <iostream>
using namespace std;
int a[105][100];
void ktl(){
    int i,j,yu,len;
    a[2][0]=1;
    a[2][1]=2;
    a[1][0]=1;
    a[1][1]=1;
    len =1;
     for(i=3;i<101;i++)
    {
        yu=0;
        for(j=1;j<=len;j++)
        {
            int t=(a[i-1][j])*(4*i-2)+yu;
            yu=t/10;
            a[i][j]=t%10;
        }   
        while(yu)
        {
            a[i][++len]=yu%10;
            yu/=10;
        }
        for(j=len;j>=1;j--)
        {
            int t=a[i][j]+yu*10;
            a[i][j]=t/(i+1);
            yu = t%(i+1);
        }       
        while(!a[i][len])
        {
            len--;
        }   
        a[i][0]=len;
    }     
}
int main()
{
    /* code */
    int n;
    ktl();
    while(~scanf("%d",&n)){
        for(int i=a[n][0];i>0;i--){
            printf("%d",a[n][i] );
        }
        printf("\n");

    }
    return 0;
}
View Code

 

hdu 1023 Train Problem II

标签:

原文地址:http://www.cnblogs.com/superxuezhazha/p/5564471.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!