Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 143429 Accepted Submission(s): 33431
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main ()
{
int T,n,a[100105];
int i,j,sum,max,s,e,t;
cin>>T;
for(i=1;i<=T;i++)
{
cin>>n;
for(j=0;j<n;j++)
cin>>a[j];
sum=a[0];
max=a[0];
t=0;
s=0;
e=0;
for(j=1;j<n;j++)
{
if(sum<0)
{
sum=0;
t=j;
}
sum+=a[j];
if(sum>max)
{
max=sum;
e=j;
s=t;
}
}
cout<<"Case"<<" "<<i<<":"<<endl;
cout<<max<<" "<<s+1<<" "<<e+1<<endl;
if(i<T)
cout<<endl;
}
return 0;
}