码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1988 Cube Stacking (数据结构-并查集)

时间:2014-08-03 18:10:30      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:数据结构   并查集   

Cube Stacking
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 18900   Accepted: 6568
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M‘ for a move operation or a ‘C‘ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


题目大意:

有N个立方体和N个格子,1~N编号,一开始i立方体在i号格子上,每个格子刚好1个立方体。现在m组操作,M a b表示将a号立方体所在的格子的全部立方体放在b号立方体所在的格子的全部立方体上面。C x表示询问x号立方体下面的立方体的个数。


解题思路:

在并查集的基础上,只需要知道x到父亲的距离以及父亲到底的距离就知道x到底的距离。sum[i]记录与根的距离,不断维护。


参考代码:
#include <iostream>
#include <vector>
#include <map>
using namespace std;

const int MAXN = 30010;
int p;
int father[MAXN], sum[MAXN], num[MAXN];

void init() {
    for (int i = 1; i <= 30000; i++) {
        father[i] = i;
        sum[i] = 0;
        num[i] = 1;
    }
}

int find_set(int x) {
    int tmp = father[x];
    if (father[x] != x) {
        father[x] = find_set(father[x]);
        sum[x] += sum[tmp];
    }
    return father[x];
}

void union_set(int x, int y) {
    x = find_set(x);
    y = find_set(y);
    if (x == y) return;
    father[x] = y;
    sum[x] += num[y];
    num[y] += num[x];
}

void solve() {
    for (int k = 0; k < p; k++) {
        char op;
        cin >> op;
        if (op == 'M') {
            int x, y, posx;
            cin >> x >> y;
            union_set(x, y);
        } else if (op == 'C') {
            int x, cnt = 0;
            cin >> x;
            find_set(x);
            cout << sum[x] << endl;
        }
    }
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> p) {
        init();
        solve();
    }
    return 0;
}


HDU 1988 Cube Stacking (数据结构-并查集),布布扣,bubuko.com

HDU 1988 Cube Stacking (数据结构-并查集)

标签:数据结构   并查集   

原文地址:http://blog.csdn.net/wujysh/article/details/38358315

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!