码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2828 Buy Tickets

时间:2014-08-03 23:26:46      阅读:353      评论:0      收藏:0      [点我收藏+]

标签:poj

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

bubuko.com,布布扣



题意 : 相当于一个队列,第i个人过来插队,插在第pos[i]个人的后面,原本pos[i]之后的人都往后退一个位置。最后输出n个人都插完队后的序列。


可以从第n个人开始考虑(下标从1开始),因为题目保证了插队正确(插在i个人的后面,紧跟着i),那么最后一个人插队的时候,前面一定有pos[n]个人,也就是说,从第n个开始考虑,这个人前面一定要存在恰好pos[n]个空位,那么,可以将问题转化:倒着插队时,第i个人站在 从左边数 恰好pos[i]+1个空位上,并且一定是这个位置。

用线段树记录每个区间的剩余的空位的数量,插进来一个人就更新本节点及祖先节点的剩余空位 并保存结果。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <ctype.h>
#define lson o << 1, l, m
#define rson o << 1|1, m+1, r
using namespace std;
typedef long long LL;
const int MAX = 0x3f3f3f3f;
const int maxn = 211111;
int n, w, ans[maxn], v[maxn], pos[maxn], res[maxn<<2];
void up(int o) {
    res[o] = res[o<<1] + res[o<<1|1];
}
void build(int o, int l, int r) {
    if(l == r) res[o] = 1;
    else {
        int m = (l+r) >> 1;
        build(lson);
        build(rson);
        up(o);
    }
}
void update(int p, int o, int l, int r) {
    if(l == r) {
        res[o] --;
        ans[l] = w;
        return ;
    }
    int m = (l+r) >> 1;
    if(res[o<<1] >= p) update(p, lson);
    else update(p - res[o<<1], rson);
    up(o);
}
int main()
{
    while(~scanf("%d", &n)) {
        build(1, 0, n-1);
        for(int i = 0; i < n; i++) 
            scanf("%d%d", &pos[i], &v[i]);
        for(int i = n-1; i >= 0; i--) {
            w = v[i];
            update(pos[i]+1, 1, 0, n-1);
        }
        for(int i = 0; i < n; i++)
            if(i < n-1) printf("%d ", ans[i]);
            else printf("%d\n", ans[i]);
    }

    return 0;
}



POJ 2828 Buy Tickets,布布扣,bubuko.com

POJ 2828 Buy Tickets

标签:poj

原文地址:http://blog.csdn.net/u013923947/article/details/38360513

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!