码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1160 FatMouse's Speed

时间:2014-08-04 11:10:17      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   strong   io   for   

FatMouse‘s Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9193    Accepted Submission(s): 4073
Special Judge

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
4 4 5 9 7
 

#include<stdio.h>
#include<algorithm>
#include<iostream>
#define M 100005
using namespace std;

int dp[M],ans[M],pre[M];
struct node
{
    int w,s,num;
}p[1015];

bool cmp(node a,node b)
{
  if(a.w==b.w)
    return (a.s>b.s);
  return (a.w<b.w);
}

int main ()
{
  int i,j;
  int k=1;
  while(cin>>p[k].w>>p[k].s)
  {
      p[k].num=k++;
  }

  sort(p+1,p+k,cmp);
  for(i=1;i<k;i++)
  {
    dp[i]=1;
    pre[i]=0;
  }

  for(i=1;i<k;i++)
  {
      for(j=1;j<i;j++)
      {
          if(p[i].w>p[j].w && p[i].s<p[j].s && dp[i]<dp[j]+1)  //重量必须严格递增(递减),速度必须严格递减(递增)
          {
              dp[i]=dp[j]+1;
              pre[i]=j;       //记录路径
          }
      }
  }
  int end;
  int max=dp[1];
  for(i=2;i<k;i++)
     if(dp[i]>max)
     {
        max=dp[i];     // 找出速度最长递减子序列的长度
        end=i;         //
     }
  cout<<max<<endl;

  for(i=1;i<k;i++)
  {
      ans[i]=end;     
      end=pre[end];  //保存路径
  }
  
  for(i=max;i>=1;i--)
    cout<<p[ans[i]].num<<endl;
return 0;

}


hdu 1160 FatMouse's Speed,布布扣,bubuko.com

hdu 1160 FatMouse's Speed

标签:des   style   color   java   os   strong   io   for   

原文地址:http://blog.csdn.net/fyxz1314/article/details/38364813

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!