码迷,mamicode.com
首页 > 其他好文 > 详细

poj2752:KMP的简单应用

时间:2016-06-17 23:44:37      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16388 Accepted: 8330

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

 

Step1. Connect the father‘s name and the mother‘s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

题意:
求出前缀与后缀相同的情况,从小到大输出他们的长度。
做法:
KMP next(fail)数组的简单应用,从next[len]一直递推到底,输出长度即可。
next数组递推过程中一定是严格递减的,所以我们可以不用排序,直接逆序输出即可。
代码如下。
 
 
/*Source Code
 
Problem: 2752       User: aclolicon
Memory: 3188K       Time: 110MS
Language: G++       Result: Accepted
Source Code*/
#include<cstdio>
#include<cstring>
#include<iostream>
#define MAXL 400050
using namespace std;
int fail[MAXL], len, ans, tot;
int a[MAXL];
char c[MAXL];
 
void getfail(){
 
    int i = 0, j = -1;
    fail[0] = -1;
    while(i != len){
        if (j == -1 || c[i] == c[j]) fail[++i] = ++j;
        else j = fail[j];
    }
}
 
int main(){
    while(~scanf("%s", c)){
        ans = 0, tot = 0;
        len = strlen(c);
        getfail();
        ans = fail[len];
        a[tot++] = len; //整个字符串肯定是
        while(ans > 0){
            a[tot++] = ans;
            ans = fail[ans];
        }
        for (int i = tot - 1; i >= 0; i--) cout << a[i] << (i == 0? \n:  );
    }
}

 

poj2752:KMP的简单应用

标签:

原文地址:http://www.cnblogs.com/hentai/p/5595270.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!