码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1159——Common Subsequence(DP)

时间:2014-08-04 17:52:18      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   strong   io   for   

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23279    Accepted Submission(s): 10242


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0



——————————————————————————————————————————————

最长公共子序列 LCS

if a[i]==b[j] 

dp[i][j]=dp[i-1][j-1]+1;

else

dp[i][j]=max(dp[i-1][j],dp[i][j-1])


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define M 1000
using namespace std;
int dp[M][M];
int main()
{
    char s1[M],s2[M];
    while(scanf("%s %s",s1,s2)!=EOF){
        memset(dp,0,sizeof dp);
        int l1=strlen(s1);
        int l2=strlen(s2);
        for(int i=1;i<=l1;++i){
            for(int j=1;j<=l2;++j){
                if(s1[i-1]==s2[j-1]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else{
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        cout<<dp[l1][l2]<<endl;
    }
    return 0;
}














HDU 1159——Common Subsequence(DP),布布扣,bubuko.com

HDU 1159——Common Subsequence(DP)

标签:des   style   color   java   os   strong   io   for   

原文地址:http://blog.csdn.net/u014141559/article/details/38370775

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!