码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1942(详解)

时间:2014-08-04 18:06:27      阅读:298      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   

Paths on a Grid
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21439   Accepted: 5259

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he‘s explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let‘s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 
bubuko.com,布布扣

Really a masterpiece, isn‘t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source

Ulm Local 2002

要么上走要么右走,共有n+m步,只要其中的n步确定了,那么剩下的m步也就确定了,所以答案为C(n+m,n);

AC代码:

#include<iostream>
using namespace std;
unsigned int C(unsigned int m,unsigned n){
    double sum=1.0;
    unsigned int t=m;
    for(unsigned int i=1;i<=n;i++){
        sum*=double(t)/double(i);
        t--;
    }
    sum+=0.5;        //四舍五入,否则会wa
    return (unsigned int)sum;
}
int main(){
    unsigned int n,m;
    while(cin>>m>>n){
        if(m==0 && n==0)
            break;
        if(m<n){
            unsigned int t=n;
            n=m;
            m=t;
        }
        cout<<(unsigned int)C(m+n,n)<<endl;
    }
    return 0;
}


poj 1942(详解),布布扣,bubuko.com

poj 1942(详解)

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/my_acm/article/details/38368721

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!