码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2229 Sumsets 完全背包求方案总数

时间:2016-06-21 20:45:59      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:

Sumsets

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

#include<stdio.h>
#include<string.h>
#define ll long long
#define mod 1000000007
#define esp 0.00000000001
const int N=1e5+10,M=1e6+10,inf=1e9;
int a[22]={1,2,4,8,16,32,64,128,256,512,1024,2048,4096,8192,16384,32768,65536,131072,262144,524288};
int dp[M];
int main()
{
    int x,y,z,i,t;
    memset(dp,0,sizeof(dp));
    dp[0]=1;
    for(i=0;i<20;i++)
    {
        for(t=a[i];t<=1000000;t++)
        dp[t]+=dp[t-a[i]],dp[t]%=inf;
    }

    while(~scanf("%d",&x))
    printf("%d\n",dp[x]);
    return 0;
}

 

poj 2229 Sumsets 完全背包求方案总数

标签:

原文地址:http://www.cnblogs.com/jhz033/p/5604864.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!