码迷,mamicode.com
首页 > 其他好文 > 详细

2016NEFU集训第n+5场 A - Chinese Girls' Amusement

时间:2016-06-22 21:51:42      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

Description

      You must have heard that the Chinese culture is quite different from that of Europe or Russia. So some Chinese habits seem quite unusual or even weird to us. 
      So it is known that there is one popular game of Chinese girls. N girls stand forming a circle and throw a ball to each other. First girl holding a ball throws it to the K-th girl on her left (1 ≤ K ≤ N/2). That girl catches the ball and in turn throws it to the K-th girl on her left, and so on. So the ball is passed from one girl to another until it comes back to the first girl. If for example N = 7 and K = 3, the girls receive the ball in the following order: 1, 4, 7, 3, 6, 2, 5, 1. 
 To make the game even more interesting the girls want to choose K as large as possible, but they want one condition to hold: each girl must own the ball during the game.

Input

Input contains one integer number N (3 ≤ N ≤ 10 2000) — the number of Chinese girls taking part in the game.

Output

Output the only number — K that they should choose.

Sample Input

7
6

Sample Output

3
1

#include <iostream>
#include <cstring>
using namespace std;
char data[3005];
int a[3005],d,c[3005];

int main()
{
    while(cin>>data)
    {
        memset(a,0,sizeof(a));
        int len1=strlen(data);
        for(int i=0;i<len1;i++)
        a[i]=data[len1-i-1]-0;
        d=0;
        for(int i=len1-1;i>=0;i--)
        {
            d=d*10+a[i];
            c[i]=d/2;
            d=d%2;
        }
        if(a[0]%2==1){
        while(c[len1-1]==0&&len1>1) len1--;
        for(int i=len1-1;i>=0;i--)
        cout<<c[i];
        cout<<endl;}
        else
        {
            if(c[0]%2==1)//得到奇数减2
            {
                if(c[0]>=2)
                c[0]-=2;
                else
                {
                    for(int i=0;i<len1;i++)
                    {
                        if(c[i]<=1)
                        {
                            c[i+1]--;
                            c[i]=(c[i]+10)-2;
                        }
                        else
                        break;
                    }
                }
            }
            else //得到偶数减1
            {
                if(c[0]>=1)
                c[0]-=1;
                else
                {
                    for(int i=0;i<len1;i++)
                    {
                        if(c[i]<=0)
                        {
                            c[i+1]--;
                            c[i]=(c[i]+10)-1;
                        }
                        else
                        break;
                    }
                }
            }
            while(c[len1-1]==0&&len1>1) len1--;
        for(int i=len1-1;i>=0;i--)
        cout<<c[i];
        cout<<endl;
        }
    }
    return 0;
}

 

2016NEFU集训第n+5场 A - Chinese Girls' Amusement

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5608564.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!