码迷,mamicode.com
首页 > 其他好文 > 详细

最低位 【杭电-HDOJ-1196】 附题

时间:2014-08-05 09:39:09      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:c语言   杭电   c   

/*
Lowest Bit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7775    Accepted Submission(s): 5714


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0

Sample Output
2
8
*/
#include<stdio.h>
#include<string.h>
int main()
{
 int n;
 while(~scanf("%d",&n),n)
 {
  //printf("%d\n",n&(-n));
  printf("%d\n",n^(n&(n-1)));
 }
 return 0;
}

最低位 【杭电-HDOJ-1196】 附题,布布扣,bubuko.com

最低位 【杭电-HDOJ-1196】 附题

标签:c语言   杭电   c   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/38379275

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!