码迷,mamicode.com
首页 > 其他好文 > 详细

poj1276

时间:2016-06-26 16:38:27      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:

 

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32067   Accepted: 11577

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

题目大意:

有各种不同面值的货币,每种面值的货币有不同的数量,请找出利用这些货币可以凑成的最接近且小于等于给定的数字cash的金额。

背包分类:多重背包

技术分享

 

#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int n,m;
    while(scanf("%d%d",&m,&n)==2){
        int *num=new int [n+1];//num[i]第i种物品的个数(第i种面额的数量)
        int *w=new int [n+1]; //w[i]第i种物品的价值(第i种面额的价值)
        int *f=new int [m+1];//f[j]记录的是 当前最接近状态j且<=j的值,dp值会累积
        int *count=new int [m+1];//计数器,限制某种物品(面额)的选取个数
        for(int i=1;i<=n;i++)
            scanf("%d%d",num+i,w+i);//本题的单个物品的“体积”等于其“价值”,所以不再开数组c[] ;均用w[]表示 
        memset(f,0,4*(m+1));//由于f申请的是动态内存,用sizeof计算长度会出错
        for(int i=1;i<=n;i++){
            memset(count,0,4*(m+1));//每更换一次面额,计数器清零
            for(int j=w[i];j<=m;j++){//对于第i种货币,其面额w[i]~m间任一个状态都可能发生
                if(f[j]<f[j-w[i]]+w[i]&&count[j-w[i]]<num[i]){//取某种面额前,必须保证这次操作之前所取该种面额的次数小于n[i]
                    f[j]=f[j-w[i]]+w[i];//选取第i个物品后,背包容量(允许取的最大金额)减少w[i]
                    count[j]=count[j-w[i]]+1;//对于当前状态j,第i种面额被抽了count[j]次
                }
            }
        }
        printf("%d\n",f[m]);
        delete num;//释放空间 
        delete w;
        delete f;
        delete count;
    }
    return 0;
}

 

poj1276

标签:

原文地址:http://www.cnblogs.com/shenben/p/5618028.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!