码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4405概率dp入门

时间:2014-05-07 11:51:37      阅读:330      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1122    Accepted Submission(s): 762


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 


/*题意:有一个飞行棋n个格子,刚开始在0这个位置,每次可以扔色子,扔到x则可以移动x格
如果到达的位置>=n则胜利
另外在棋盘上还有m对点x,y表示在位置x可以直接飞行到y
求到达胜利平均的扔色子次数

分析:求期望,假设dp[i]表示在点i位置到达胜利所需要的平均次数,则我们需要求dp[0] 
dp[n],dp[n+1]....等是知道的:为0
而对于dp[i]可以到达:
如果点i不能飞行:dp[i+1],dp[i+2],dp[i+3],dp[i+4],dp[i+5],dp[i+6]且等概率:1/6
如果i点位置可以飞行则可以到达飞行的点 
由E(aA+bB+cC+dD...)=aEA+bEB+....
可知:dp[i]=1/6*dp[i+1]+1/6*dp[i+2]... 
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=100000+10;
int n,m,size;
int head[MAX];
double dp[MAX];//dp[i]表示从i到达目标所需要的平均次数(期望)

struct Node{
	int y,next;
	Node(){}
	Node(int Y,int NEXT):y(Y),next(NEXT){}
}node[MAX];

void Init(){
	memset(head,-1,sizeof head);
	memset(dp,0,sizeof dp);
	size=0;
}

void InsertNode(int x,int y){
	node[size]=Node(y,head[x]);
	head[x]=size++;
}

double Solve(int x){
	double sum=0,num=0;
	for(int i=head[x];i != -1;i=node[i].next){
		sum+=dp[node[i].y];
		++num;
	}
	return sum/num;
}

int main(){
	int x,y;
	while(~scanf("%d%d",&n,&m),n+m){
		Init();
		for(int i=0;i<m;++i){
			scanf("%d%d",&x,&y);
			InsertNode(x,y);
		}
		for(int i=n-1;i>=0;--i){
			if(head[i] != -1){
				dp[i]=Solve(i);
			}else{
				dp[i]=(dp[i+1]+dp[i+2]+dp[i+3]+dp[i+4]+dp[i+5]+dp[i+6])/6+1;
			}
		}
		printf("%.4lf\n",dp[0]);
	}
	return 0;
}


hdu4405概率dp入门,布布扣,bubuko.com

hdu4405概率dp入门

标签:des   style   blog   class   code   java   

原文地址:http://blog.csdn.net/xingyeyongheng/article/details/25181515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!