码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5680 zxa and set(水题)

时间:2016-07-03 19:27:16      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5680

zxa and set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 411    Accepted Submission(s): 310


Problem Description
zxa has a set A={a1,a2,?,an}, which has n elements and obviously (2n?1) non-empty subsets.

For each subset B={b1,b2,?,bm}(1mn) of A, which has m elements, zxa defined its value as min(b1,b2,?,bm).

zxa is interested to know, assuming that Sodd represents the sum of the values of the non-empty sets, in which each set B is a subset of A and the number of elements in B is odd, and Seven represents the sum of the values of the non-empty sets, in which each set B is a subset of A and the number of elements in B is even, then what is the value of |Sodd?Seven|, can you help him?
 

Input
The first line contains an positive integer T, represents there are T test cases.

For each test case:

The first line contains an positive integer n, represents the number of the set A is n.

The second line contains n distinct positive integers, repersent the elements a1,a2,?,an.

There is a blank between each integer with no other extra space in one line.

1T100,1n30,1ai109
 

Output
For each test case, output in one line a non-negative integer, repersent the value of |Sodd?Seven|.
 

Sample Input
3 1 10 3 1 2 3 4 1 2 3 4
 

Sample Output
10 3 4
Hint
For the first sample, $A=\{10\}$, which contains one subset $\{10\}$ in which the number of elements is odd, and no subset in which the number of elements is even, therefore $S_{odd}=10,S_{even}=0,|S_{odd}-S_{even}|=10$. For the second sample, $A=\{1,2,3\}$, which contains four subsets $\{1\},\{2\},\{3\},\{1,2,3\}$ in which the number of elements is odd, and three subsets $\{1,2\},\{2,3\},\{1,3\}$ in which the number of elements is even, therefore $S_{odd}=1+2+3+1=7,S_{even}=1+2+1=4,|S_{odd}-S_{even}|=3$.
 

Source

题目大意:简答的说就是求最大值~~~~~

详见代码。
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

int a[1010];

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n;
        scanf("%d",&n);
        for (int i=0;i<n;i++)
        {
            scanf ("%d",&a[i]);
        }
        sort(a,a+n);
        printf("%d\n",a[n-1]);
    }
    return 0;
}



hdu 5680 zxa and set(水题)

标签:

原文地址:http://blog.csdn.net/qiqi_skystar/article/details/51812319

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!