码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3352-Road Construction

时间:2014-08-05 22:42:30      阅读:240      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   art   

Road Construction
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8652   Accepted: 4323

Description

It‘s almost summer time, and that means that it‘s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

裸的计算边双连通分量。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
using namespace std;
const int maxn = 1000+10;
vector<int> G[maxn];
int n,m;
int dfn[maxn],lown[maxn];
int du[maxn];
int dfs_clk;

void init(){
    for(int i = 0; i <= n; i++){
        G[i].clear();
    }
    dfs_clk = 0;
    memset(dfn,0,sizeof dfn);
    memset(du,0,sizeof du);
}
int dfs(int u,int fa){
    int lowu = dfn[u] = dfs_clk++;
    for(int i = 0; i < G[u].size(); i++){
        int d = G[u][i];
        if(!dfn[d]){
            int lowv = dfs(d,u);
            lowu = min(lowu,lowv);
        }
        else if(dfn[d] < dfn[u] && d != fa){
            lowu = min(lowu,dfn[d]);
        }
    }
    lown[u] = lowu;
    return lowu;
}
int main(){

    while(~scanf("%d%d",&n,&m)){
        init();
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            G[a].push_back(b);
            G[b].push_back(a);
        }
        dfs(1,-1);
        for(int i = 1; i <= n; i++){
            for(int j = 0; j < G[i].size(); j++){
                int k = G[i][j];
                if(lown[i] != lown[k]){
                    du[lown[i]]++;//统计入度
                }
            }
        }
        int block = 0;
        for(int i = 0; i < dfs_clk; i++){
            if(du[i]==1) ++block;
        }
        printf("%d\n",(block+1)/2);
    }
    return 0;
}


POJ3352-Road Construction,布布扣,bubuko.com

POJ3352-Road Construction

标签:des   style   color   os   io   strong   for   art   

原文地址:http://blog.csdn.net/mowayao/article/details/38390427

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!