码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2674 N!Again 【数学】

时间:2014-08-06 08:25:41      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:hdu2674

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3440    Accepted Submission(s): 1865


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven‘s finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
4 5
 

Sample Output
24 120
 
因为2009=7*7*41, 所以41及往后的阶乘对2009取余都为0.

#include <stdio.h>

int arr[42] = {1, 1};

int main()
{
	int i;
	for(i = 2; i < 42; ++i)
		arr[i] = (arr[i-1] * i) % 2009;
	while(scanf("%d", &i) == 1){
		if(i < 42) printf("%d\n", arr[i]);
		else printf("0\n");
	}
	return 0;
}


HDU2674 N!Again 【数学】,布布扣,bubuko.com

HDU2674 N!Again 【数学】

标签:hdu2674

原文地址:http://blog.csdn.net/chang_mu/article/details/38390975

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!