码迷,mamicode.com
首页 > 其他好文 > 详细

简单的二分HDU2199

时间:2014-08-06 10:33:21      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

原题http://acm.hdu.edu.cn/showproblem.php?pid=2199

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8441    Accepted Submission(s): 3902


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


 

Sample Input
2 100 -4


 

Sample Output
1.6152 No solution!


 

Author
Redow
//一道简单的二分。首先判断下在那些范围是一定有解的
//然后不断的缩小范围就可以了
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
__int64 Y;
const double d = 1e-8;

double f(double m){
	if(Y-(8*m*m*m*m+7*m*m*m+2*m*m+3*m+6)>=1e-20){
		return 1;
	}
	else{
		return 0;
	}
}

//d//ouble f1(double x){/
//	return (8*x*x*x*x+7*x*x*x+2*x*x+3*x+6-Y);
//}

int main(){
	int T;

	while(~scanf("%d",&T)){
		while(T--){
			scanf("%I64d",&Y);
			if(Y<6 || Y>807020306){
				printf("No solution!\n");
				continue;
			}
			else{
				double l = 0.0;
				double r = 100.0;
				int flag = 0;
				while(r-l > d){
					double mid = (l+r)/2;
					if(f(mid) == 1){
						l = mid;
					}
					else{
						r = mid;
					}
				}
				printf("%.4lf\n",l);
				//if(flag == 0){
				//	printf("No solution!\n");
				//}
			}
		}
	}

	return 0;
}


 

简单的二分HDU2199,布布扣,bubuko.com

简单的二分HDU2199

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/zcr_7/article/details/38396229

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!