码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1067-Gap(bfs+哈希)

时间:2016-07-11 17:02:41      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Let‘s play a card game called Gap. You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.
First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.
技术分享
Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on.
Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.
技术分享
At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor.
In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a gap.
The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.
技术分享
Your task is to find the minimum number of moves to reach the goal layout.
 
Input
The input starts with a line containing the number of initial layouts that follow.
Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.
 
Output
For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce "-1".
 
Sample Input
4
12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11
 
26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15
 
17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41
 
27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31
 
Sample Output
0
33
60
-1
 
题意:给出表如第一个图,给出每个数,共有28个数,首先要将11,21,31,41放到前面去如第二个图,然后每次可以挑选一个空位把某个数放在此位置,但是
要保证此数恰好是空位左边的数的后一个数,比如空位左边的数是42,则只能把43移到空位去。如果是47的话是没有后一个数的。
 
解析:总共有32个数,用哈希保存状态。然后bfs即可。详见代码实现。
 
代码

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<sstream>
#include<algorithm>
#include<utility>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
#include<iterator>
#include<stack>
using namespace std;
const
int INF=1e9+7;
const
int eps=0.0000001;
typedef
__int64 LL;
const
LL mod=1000007;
int
maze[4][8];
LL Hash[mod];
LL base[32];
struct
node
{

    int
px[4],py[4]; //保存四个空位
    int S[4][8];     //整个图
    int dist;
}
Nod[100005];
int
id;
queue<int> que;

int
goal[4][8]={    //最终状态
{ 11,12,13,14,15,16,17,0 },
{
21,22,23,24,25,26,27,0 },
{
31,32,33,34,35,36,37,0 },
{
41,42,43,44,45,46,47,0 }
};

LL G;
void
GetBase()  //打出2^i
{
    base[0]=1;
    for
(int i=1;i<32;i++) base[i]=base[i-1]*2;
}

int
GetId(int x,int y){ return x*8+y; }
void
SetHead()
{

    for
(int i=0;i<4;i++)
        for
(int j=1;j<8;j++)
    {

        int
a=maze[i][j]/10;   
        int
b=maze[i][j]%10;
        if
(b==1) { maze[a-1][0]=maze[i][j]; maze[i][j]=0; } //把11,21,31,41挑出来
    }
}

LL GetHash(int S[4][8])
{

    LL ret=0;
    for
(int i=0;i<4;i++)
        for
(int j=0;j<8;j++) ret+=(LL)S[i][j]*base[GetId(i,j)];  //得到哈希值
    return ret;
}

bool
InsertHash(LL val)
{

   LL v=val%mod;
   while
(Hash[v]!=-1&&Hash[v]!=val)  v=(v+10)%mod;   //判重
   if(Hash[v]==-1){ Hash[v]=val; return true; }  //可以插入
   return false;
}

void
init()
{

    memset(Hash,-1,sizeof(Hash));
    while
(!que.empty())  que.pop();
    id=0;
    G=GetHash(goal);
    int
k=0;
    int
cur=id++;
    for
(int i=0;i<4;i++)
        for
(int j=0;j<8;j++)
    {

        Nod[cur].S[i][j]=maze[i][j];
        if
(maze[i][j]==0){ Nod[cur].px[k]=i; Nod[cur].py[k++]=j; }  //得到最初的状态
    }
    Nod[cur].dist=0;
    que.push(cur);
}

void
Change_S(node& e,int x,int y,int pick,int k)
{

    for
(int i=0;i<4;i++)
        for
(int j=0;j<8;j++)
        if
(e.S[i][j]==pick)
    {

        e.S[i][j]=0;
        e.S[x][y]=pick;
        e.px[k]=i; e.py[k]=j;
        return
;
    }
}

void
AddNode(int now)
{

    node& e=Nod[now];
    for
(int i=0;i<4;i++)
    {

        int
x=e.px[i];
        int
y=e.py[i];
        int
pre=e.S[x][y-1];
        if
(pre==0) continue;  //也是空位不管

        int
a=pre/10;
        int
b=pre%10;
        if
(b==7) continue;  //不能是*7

        int
pick=pre+1;
        node t=e;
        t.dist++;
        Change_S(t,x,y,pick,i);
        LL nowG=GetHash(t.S);
        if
(!InsertHash(nowG)) continue;  //能否插入

        int
cur=id++;
        Nod[cur]=t;
        que.push(cur);
    }
}

int
solve()
{

    SetHead();
    init();
    while
(!que.empty())
    {

        int
now=que.front();  que.pop();
        node& e=Nod[now];
        LL nowG=GetHash(e.S);
        if
(nowG==G) return e.dist;  //找到解
        AddNode(now);
    }

    return
-1;
}

int
main()
{

    int
T;
    GetBase();
    cin>>T;
    while
(T--)
    {

        memset(maze,0,sizeof(maze));
        for
(int i=0;i<4;i++)
            for
(int j=1;j<8;j++) cin>>maze[i][j];
        printf("%d\n",solve());
    }

    return
0;
}

hdu1067-Gap(bfs+哈希)

标签:

原文地址:http://www.cnblogs.com/wust-ouyangli/p/5660613.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!