码迷,mamicode.com
首页 > 其他好文 > 详细

Elevator

时间:2016-07-13 00:57:32      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS     Memory Limit:32768KB     64bit

IO Format:%I64d & %I64u

Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. 

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled. 
 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed. 
 

Output

Print the total time on a single line for each test case. 
 

Sample Input

1 2
3 2 3 1
0
 

Sample Output

17
41
 
AC Code-- Java
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n;
		while ((n = sc.nextInt()) != 0) {
			int start = 0;
			int t = 0;
			while (n-- != 0) {
				int j = sc.nextInt();
				if (j > start) {
					t += 6 * (j - start);
				} else {
					t += 4 * (start - j);
				}
				start = j;
				t += 5;
			}
			System.out.println("" + t);
		}
	}
}

  

Elevator

标签:

原文地址:http://www.cnblogs.com/A--Q/p/5665206.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!