码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--数字位数相加--HDOJ 1013--Digital Roots--水

时间:2016-07-13 17:40:36      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ 题目地址:传送门


Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 68962    Accepted Submission(s): 21568


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24 39 0
 

Sample Output
6 3

题意:给定一个数字,把数字的每一个位数相加,以此反复,直到这个相加之后的数字是一个个位数,


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<memory.h>
using namespace std;
int sumnum(int n){
   int root=n;
   while(root>9){
        root=0;
        while(n){
            root+=n%10;
            n/=10;
        }
        n=root;
   }
   return root;
}
int main(){
    string s;
    while(cin>>s){
        if(s=="0")
            break;
        int num=0;
        for(int i=0;i<s.size();i++){
            num+=s[i]-'0';
        }
        printf("%d\n",sumnum(num));
    }
}






ACM--数字位数相加--HDOJ 1013--Digital Roots--水

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/51882612

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!