标签:des style color os io strong for ar
Tree Recovery
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 11365 |
|
Accepted: 7128 |
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
D
/
/
B E
/ \
/ \
A C G
/
/
F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
前序遍历的第一个点必定是根节点,在对应的中序遍历中找到这个点,那么在中序序列该点左边的子序列必定是左子树,右边是右子树,于是就这样递归下去,便能找到后序序列。
#include <stdio.h>
#include <string.h>
#define maxn 28
char str1[maxn], str2[maxn];
void traverse(int l1, int r1, int l2, int r2)
{
if(l1 > r1) return;
int rt;
rt = strchr(str2, str1[l1]) - str2;
traverse(l1 + 1, rt - l2 + l1, l2, rt - 1);
traverse(rt-l2+l1+1, r1, rt+1, r2);
putchar(str2[rt]);
}
int main()
{
int len;
while(scanf("%s%s", str1, str2) == 2){
len = strlen(str1);
traverse(0, len - 1, 0, len - 1);
printf("\n");
}
return 0;
}
POJ2255 Tree Recovery 【树的遍历】,布布扣,bubuko.com
POJ2255 Tree Recovery 【树的遍历】
标签:des style color os io strong for ar
原文地址:http://blog.csdn.net/chang_mu/article/details/38395677