码迷,mamicode.com
首页 > 其他好文 > 详细

Prime Distance(二次筛素数)

时间:2014-08-06 19:06:42      阅读:319      评论:0      收藏:0      [点我收藏+]

标签:筛选法求素数

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

解题思路:

这题做得我都是泪,不断地TLE,好不容易优化好了,又RE,代码也写得很龊。就是正常的二次筛选素数。由于数据很大,第一次筛出46500以内的素数,再根据此筛选出区间内的素数。

注意:虽然给的数没有超int范围,但两数相乘是会超int范围的,我也是在这里RE了。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int N = 1000005;
const int M = 46500;
const int INF = 999999999;
bool notprime[N];
int prime_1[M + 1], prime_2[N];
int num_1 = 0, num_2;
void Prime1()  // 第一次筛出46500以内的素数
{
    memset(notprime, false, sizeof(notprime));
    for(int i = 2; i <= M; i++)
        if(!notprime[i])
        {
            prime_1[num_1++] = i;
            for(int j = 2 * i; j <= M; j += i)
                notprime[j] = true;
        }
}
void Prime2(int l, int u)  // 第二次筛出给定范围内的素数
{
    memset(notprime, false, sizeof(notprime));
    num_2 = 0;
    if(l < 2)
        l = 2;
    int k = sqrt(u * 1.0);
    for(int i = 0; i < num_1 && prime_1[i] <= k; i++)
    {
        int t = l / prime_1[i];
        if(t * prime_1[i] < l)
            t++;
        if(t <= 1)
            t = 2;
        for(int j = t; (long long)j * prime_1[i] <= u; j++)  // 相乘会超范围,用long long
            notprime[j * prime_1[i] - l] = 1;
    }
    for(int i = 0; i <= u - l; i++)
        if(!notprime[i])
            prime_2[num_2++] = i + l;
}
int main()
{
    int l, u, dis, a_1, b_1, a_2, b_2, minn, maxx;;
    Prime1();
    while(scanf("%d%d", &l, &u) != EOF)
    {
        minn = INF, maxx = -1;
        Prime2(l, u);
        if(num_2  < 2)
        {
            printf("There are no adjacent primes.\n");
            continue;
        }
        for(int i = 1; i < num_2 && prime_2[i] <= u; i++)
        {
            dis = prime_2[i] - prime_2[i - 1];
            if(dis > maxx)
            {
                a_1 = prime_2[i - 1];
                a_2 = prime_2[i];
                maxx = dis;
            }
            if(dis < minn)
            {
                b_1 = prime_2[i-1];
                b_2 = prime_2[i];
                minn = dis;
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n", b_1, b_2, a_1, a_2);
    }
    return 0;
}



Prime Distance(二次筛素数),布布扣,bubuko.com

Prime Distance(二次筛素数)

标签:筛选法求素数

原文地址:http://blog.csdn.net/userluoxuan/article/details/38404185

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!