码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--最少(n+1)/2--HDOJ 1029--Ignatius and the Princess IV--水

时间:2016-07-15 20:52:58      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ题目地址:传送门


Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 26494    Accepted Submission(s): 11217


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
3 5 1
 

题意:给定的数中哪个数是大于(n+1)/2,并且是最大的


#include<stdio.h>
#include<iostream>
#include<memory.h>
using namespace std;
int res[1000000];
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        memset(res,0,sizeof(res));
        int temp,result=0;
        int index=(n+1)/2;
        for(int i=1;i<=n;i++){
            scanf("%d",&temp);
            res[temp]++;
            if(res[temp]>=index){
                result=temp;
                index=res[temp];
            }
        }
        printf("%d\n",result);
    }
}






ACM--最少(n+1)/2--HDOJ 1029--Ignatius and the Princess IV--水

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/51917775

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!