码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1690 Bus System(Floyd)

时间:2014-08-06 19:27:02      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:floyd   最短路   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1690


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

bubuko.com,布布扣


Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 
Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 
Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 
Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 
Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 
Source


代码如下:

#include <cstdio>
#include <cstring>
#include <cmath>
#define INF 1e18
#define MAXN 117
__int64 dis[MAXN][MAXN];
__int64 L1, L2, L3, L4;
__int64 C1, C2, C3, C4;
__int64 f[MAXN];
int n, m;
__int64 min(__int64 a, __int64 b)
{
    return a < b ? a:b;
}
void init()
{
    for(int i = 1; i <= n; i++)
    {
        for(int j = 1; j <= n; j++)
        {
            dis[i][j] = INF;
        }
    }
}
void Floyd()
{
    for(int k = 1; k <= n; k++)
    {
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                dis[i][j] = min(dis[i][j],dis[i][k]+dis[k][j]);
            }
        }
    }
}

__int64 cal(__int64 x)
{
    if(x > 0 && x <= L1)
        return C1;
    if(x > L1 && x <= L2)
        return C2;
    if(x > L2 && x <= L3)
        return C3;
    if(x > L3 && x <= L4)
        return C4;

        return INF;
}

int main()
{
    int t;
    int i, j;
    __int64 s, e;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d%I64d",&L1,&L2,&L3,&L4);
        scanf("%I64d%I64d%I64d%I64d",&C1,&C2,&C3,&C4);
        scanf("%d%d",&n,&m);
        init();
        memset(f,0,sizeof(f));
        for(i = 1; i <= n; i++)
        {
            scanf("%I64d",&f[i]);
        }
        for(i = 1; i < n; i++)
        {
            for(j = i+1; j <= n; j++)
            {
                dis[i][j] = dis[j][i] = cal(fabs(f[i]-f[j]));
            }
        }
        
        Floyd();
        
        printf("Case %d:\n",++cas);
        for(i = 1; i <= m; i++)
        {
            scanf("%I64d%I64d",&s,&e);
            if(dis[s][e] != INF)
                printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",s,e,dis[s][e]);
            else
                printf("Station %I64d and station %I64d are not attainable.\n",s,e);
        }
    }
    return 0;
}


hdu 1690 Bus System(Floyd),布布扣,bubuko.com

hdu 1690 Bus System(Floyd)

标签:floyd   最短路   

原文地址:http://blog.csdn.net/u012860063/article/details/38401219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!