码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ 2456

时间:2016-07-17 09:53:50      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:

 

Description

给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。

Input

第1行一个正整数n。
第2行n个正整数用空格隔开。

Output

    一行一个正整数表示那个众数。

Sample Input

5
3 2 3 1 3

Sample Output

3

HINT

 

100%的数据,n<=500000,数列中每个数<=maxlongint。


 


zju2132 The Most Frequent Number

 

Source

 技术分享

 

AC代码:
#include<cstdio>
using namespace std;
int n,t,cnt;
int main(){
    scanf("%d",&n);
    for(int i=1,x;i<=n;i++){
        scanf("%d",&x);
        if(x==t) cnt++;
        else{
            cnt--;
            if(cnt<=0) cnt=1,t=x;
        }
    }
    printf("%d",t);
    return 0;
}

 

BZOJ 2456

标签:

原文地址:http://www.cnblogs.com/shenben/p/5677208.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!