码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5720 Wool

时间:2016-07-19 10:35:10      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Wool

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 647    Accepted Submission(s): 185


Problem Description
At dawn, Venus sets a second task for Psyche.

She is to cross a river and fetch golden wool from violent sheep who graze on the other side.

The sheep are wild and tameless, so Psyche keeps on throwing sticks to keep them away.

There are n技术分享 sticks on the ground, the length of the i技术分享-th stick is a技术分享i技术分享技术分享.

If the new stick she throws forms a triangle with any two sticks on the ground, the sheep will be irritated and attack her.

Psyche wants to throw a new stick whose length is within the interval [L,R]技术分享. Help her calculate the number of valid sticks she can throw next time.
 

Input
The first line of input contains an integer T技术分享(1T10)技术分享, which denotes the number of test cases.

For each test case, the first line of input contains single integer n,L,R技术分享(2n10技术分享5技术分享,1LR10技术分享18技术分享)技术分享.

The second line contains n技术分享 integers, the i技术分享-th integer denotes a技术分享i技术分享技术分享(1a技术分享i技术分享10技术分享18技术分享)技术分享.
 

Output
For each test case, print the number of ways to throw a stick.
 

Sample Input
2 2 1 3 1 1 4 3 10 1 1 2 4
 

Sample Output
2 5
Hint
In the first example, $ 2, 3 $ are available. In the second example, $ 6, 7, 8, 9, 10 $ are available.
 

Source


题意大致是:给出已有木棍个数及长度 然后给出可用的木棍的长度范围 现在要再放一根木棍但是要使得任意三根木棍都不能组成三角形 问放的这根木棍的长度共有多少种选择

秉持着两边之和小于等于第三边不能构成三角形

/*

测试数据:
1000
4 1 20
5 6 7 8

4 1 150
2 3 7 100

2 1 1000000000000000000
2 3

4 1 1000000000000000000
2 3 7 100

4 1000000 1000000000000000
2 3 7 100

4 2 3
1 1 1 1

4 1 100
2 3 9 100

2 2 2
1 5

2 2 2
1 1


2 2 2
2 3
*/




 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100010
using namespace std;
long long a[maxn];
int main()
{
    int t,n;
    long long l,r,xl,xr,ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%I64d%I64d",&n,&l,&r);
        for(int i=1;i<=n;++i)
            scanf("%I64d",&a[i]);
        ans=0;
        sort(a+1,a+n+1);
        xl=l>1?l:1;
        xr=(a[2]-a[1])<=r?(a[2]-a[1]):r;
        if(xl<=xr)
            ans+=xr-xl+1;
        for(int i=3;i<=n;++i)
        {
            if((a[i]-a[i-1])>=l&&(a[i-1]+1)<=r&&(a[i]-a[i-1])>=a[i-1]+a[i-2])
            {
                xl=l>a[i-1]+a[i-2]?l:(a[i-1]+a[i-2]);
                xr=r<a[i]-a[i-1]?r:(a[i]-a[i-1]);
                if(xl<=xr)
                    ans+=xr-xl+1;
            }
        }
        if(a[n]+a[n-1]<=r)
        {
            if(a[n]+a[n-1]>=l)
                ans+=r-(a[n]+a[n-1])+1;
            else
                ans+=r-l+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


 

HDOJ 5720 Wool

标签:

原文地址:http://blog.csdn.net/wyjwyl/article/details/51944044

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!