码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--字母反转--HDOJ 1062--Text Reverse--字符串

时间:2016-07-19 11:04:03      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ题目地址:传送门


Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26156    Accepted Submission(s): 10157


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
3 olleh !dlrow m‘I morf .udh I ekil .mca
 

Sample Output
hello world! I‘m from hdu. I like acm.
Hint
Remember to use getchar() to read ‘\n‘ after the interger T, then you may use gets() to read a line and process it.

题意:输入一个字符串,将字符串中的 单词反转后输出,一次反转一个


#include<stdio.h>
#include<iostream>
#include<memory.h>
#include<string.h>
#include<stack>
using namespace std;
int main(){
    int n;
    char ch;
    cin>>n;
    getchar();
    while(n--){
        string s;
        stack<char> stack_s;
        int index=0;
        while(true){
            ch=getchar();
            if(ch==' '||ch=='\n'||ch==EOF){
                while(!stack_s.empty()){
                    printf("%c",stack_s.top());
                    stack_s.pop();
                }
                if(ch=='\n'||ch==EOF)
                    break;  /*绝对不能少,控制输出结束*/
                printf(" ");
            }else{
                stack_s.push(ch);//入栈

            }

        }
        printf("\n");

    }
}






ACM--字母反转--HDOJ 1062--Text Reverse--字符串

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/51934894

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!