码迷,mamicode.com
首页 > 其他好文 > 详细

RunningMan【第六届福建省大学生程序设计竞赛-重现赛】

时间:2016-07-19 11:05:55      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:

RunningMan

Time Limit: 1000ms
Memory Limit: 32768KB
This problem will be judged on FZU. Original ID: 2221
64-bit integer IO format: %I64d      Java class name: Main

ZB loves watching RunningMan! There‘s a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there‘s one line consists of two integers N and M. (1 <= N, M <= 10^9).

Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn‘t such an arrangement. (Without the quotation marks.)

Sample Input

2
100 100
200 100

Sample Output

No
Yes

Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.


#include<stdio.h>
int main (void)
{
    int s,n;
    scanf("%d",&s);
    while(s--)
    {
        int m;
        scanf("%d%d",&n,&m);
        if(m%2)
        {
            if(n>=((m-1)/2)*3) printf("Yes\n");
            else printf("No\n");
        }
        else
        {
            if(n>=((m/2)*3-1)) printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}





RunningMan【第六届福建省大学生程序设计竞赛-重现赛】

标签:

原文地址:http://blog.csdn.net/qq_24653023/article/details/51933675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!