码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1560(迭代加深搜索)

时间:2016-07-19 15:34:02      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:

DNA sequence

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1914    Accepted Submission(s): 946


Problem Description
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given "ACGT","ATGC","CGTT" and "CAGT", you can make a sequence in the following way. It is the shortest but may be not the only one.

技术分享
 

 

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
 

 

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
 

 

Sample Input
1
4
ACGT
ATGC
CGTT
CAGT
 
Sample Output
8
思路:迭代加深搜索。含义:在不知道迭代深度的前提下,依次探索每次的搜索深度。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
const int MAXN=10;
struct Node{
    char s[MAXN];
    int top,len;
}seq[MAXN];
int n,limit;
int res;
char buf[4]={A,T,C,G};
bool dfs(int dep)
{
    int mark=0;
    int remain=0;
    for(int i=0;i<n;i++)
    {
        if(seq[i].top==seq[i].len)
        {
            mark++;
        }
        else
        {
            remain=max(seq[i].len-seq[i].top,remain);
        }
    }
    if(mark==n)
    {
        res=min(dep,res);
        return true;
    }
    if(remain+dep>limit)
    {
        return false;//重要剪枝 
    } 
    for(int k=0;k<4;k++)
    {
        char ch=buf[k];
        int vis[MAXN]={0};
        bool flag=false;
        for(int i=0;i<n;i++)
        {
            if(seq[i].s[seq[i].top]==ch)
            {
                flag=true;
                seq[i].top++;
                vis[i]=1;
            }
        }
        if(flag) 
        {
            if(dfs(dep+1))
            {
                return true;
            }
            for(int i=0;i<n;i++)
            {
                if(vis[i])
                {
                    seq[i].top--;
                }
            }
        }
    }
    return false;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        limit=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",seq[i].s);
            seq[i].len=strlen(seq[i].s);
            seq[i].top=0;
            limit=max(limit,seq[i].len);    
        }    
        res=0x3f3f3f3f;
        while(!dfs(0))
        {
            limit++;//迭代加深搜索
        }
        printf("%d\n",res);
    }
    return 0;
}

 

HDU1560(迭代加深搜索)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5684888.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!