码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence 最长递增序列

时间:2016-07-19 20:28:32      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

 

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题目大意:求最长递增序列的长度

题解:题解写在另一篇

--------http://www.cnblogs.com/Noevon/p/5685975.html

#include <stdio.h>
int b[1010], a[1010];
int main()
{
    int i, j, n, max;
    scanf("%d", &n);
    for(i=1;i<=n;i++)
        scanf("%d", &a[i]);
    a[0] = 0;
    for(i=1;i<=n;i++)
    {
        for(max=0,j=i;j>=0;j--)
            if(a[i]>a[j]&&max<b[j])
                max=b[j];
        b[i] = max+1;
    }
    for(max=0,i=0;i<=n;i++)
        if(max < b[i])
        max = b[i];
        printf("%d\n", max);

        return 0;
}

 

 

POJ 2533 Longest Ordered Subsequence 最长递增序列

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5686011.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!