码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3903 Stock Exchange

时间:2016-07-19 23:33:27      阅读:358      评论:0      收藏:0      [点我收藏+]

标签:

 

 
The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

Source

Southeastern European Regional Programming Contest 2008
#include <stdio.h>
#include <string.h>
int b[100100];
int a[100111];
int f(int a[], int n)
{

    int t, i, z ,y, mid;
    b[t=1] = a[0];
    for(i=1;i<n;i++)
        {
            if(a[i]>b[t])
                b[++t] = a[i];
            else
            {
                z=0;y=t;
                while(z<=y)
                {
                     mid = (z+y)/2;
                    if(b[mid] >= a[i])
                        y = mid-1;
                    else
                        z = mid+1;
                }
                b[z] = a[i];
            }
        }
    return t;
}
int main()
{

    int n, i, k, j;
    while (~scanf("%d", &n))
    {
    for(j=0;j<100010;j++)
        b[j] = 0;
    for(i=0;i<n;i++)
        scanf("%d", &a[i]);
    printf("%d\n", f(a, n));

    }
    return 0;
}

 

 

POJ 3903 Stock Exchange

标签:

原文地址:http://www.cnblogs.com/Noevon/p/5686584.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!