码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--大数相加--HDOJ 1002--A + B Problem II

时间:2016-07-21 16:22:13      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ题目地址:传送门


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 315080    Accepted Submission(s): 61120


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

一:C++

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int main(){
    int n;
    cin>>n;
    getchar();
    string a,b,c;
    int index=1;
    int result=n;
    while(n--){
        cin>>a>>b;
        printf("Case %d:\n",index++);
        printf("%s + %s = ",a.c_str(),b.c_str());
        c="";
        int len_a,len_b;
        len_a=a.size();
        len_b=b.size();
        reverse(a.begin(),a.begin()+len_a);
        reverse(b.begin(),b.begin()+len_b);
        if(len_a>len_b){
            for(int i=0;i<(len_a-len_b);i++){
                b+='0';
            }
            len_b=len_a;
        }else{
            for(int i=0;i<(len_b-len_a);i++){
                a+='0';
            }
            len_a=len_b;
        }
        int temp,te=0,aa,bb;
        for(int i=0;i<len_a;i++){
            aa=a[i]-'0';
            bb=b[i]-'0';
            temp=aa+bb+te;
            if(temp>=10){
                te=1;
                c+=((temp-10)+'0');
            }else{
                te=0;
                c+=((temp)+'0');
            }
        }
        if(te>0){
            c+='1';
        }
        int len_c=c.size();
         reverse(c.begin(),c.begin()+len_c);
         if(index-1==result){
            cout<<c<<endl;
         }else{
           cout<<c+"\n"<<endl;
         }


    }


}


二:JAVA


import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    /**
     * 用来处理大数
     * @param args
     */
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int n= cin.nextInt();
        int index=1;
        while(n-->0){
            String s1=cin.next();
            String s2=cin.next();
            BigInteger a=new BigInteger(s1); 
            BigInteger b= new BigInteger(s2);
            BigInteger c= a.add(b);
            System.out.println("Case " + (index++) + ":");
            System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
            if(n>0)
                System.out.println("");
        }
        cin.close();
    }

}






ACM--大数相加--HDOJ 1002--A + B Problem II

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/51983502

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!