码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5734 Acperience

时间:2016-07-22 09:59:03      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5734

                           Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 371    Accepted Submission(s): 191


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1}) and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that  denotes the Euclidean norm (i.e. X=x21+?+x2n−−−−−−−−−−−√, where X=(x1,x2,...,xn)).
 

 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000).
 

 

Output
For each test case, output the minimum value of WαB2 as an irreducible fraction "p/q" where pq are integers, q>0.
 

 

Sample Input
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

 

Sample Output
5/1 0/1 10/1

 

题意:已知 B=(b1,b2,...,bn(bi{+1,1})     α0     W=(w1,w2,...,wn)

        求∑(W+B*α)^2最小是多少?

题解:

技术分享

 α为-b/2a时为最低点,那时候最小

源代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        long long wi,sum=0,sum2=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&wi);
            sum+=abs(wi);
            sum2+=wi*wi;
        }
        long long a=n*sum2-(sum*sum);
        long long b=n;
        long long c=gcd(a,b);
        long long aa=a/c;
        long long bb=b/c;
        printf("%I64d/%I64d\n",aa,bb);
    }
    return 0;
}

 

hdu 5734 Acperience

标签:

原文地址:http://www.cnblogs.com/q-c-y/p/5693869.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!