标签:
Description
Input
Output
Sample Input
Sample Output
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
AC代码:
sort函数:
#include<iostream>
#include<algorithm>
using namespace std;
int a[1000001];
int main()
{
int n;
while(cin>>n)
{
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n);
cout<<a[n/2]<<endl;
}
return 0;
}
冒泡法:
标签:
原文地址:http://www.cnblogs.com/lbyj/p/5696881.html
#include<iostream> #include<cstdio> int main() { int n,a[20000]; while(~scanf("%d",&n)&&n) { for(int i=0;i<n;i++) scanf("%d",&a[i]); for(int i=0;i<n-1;i++) { for(int j=i+1;j<n;j++) { if(a[i]>a[j]) { int m; m=a[i]; a[i]=a[j]; a[j]=m ; } } } printf("%d\n",a[n/2]); } return 0; }
分析:水题,用sort函数排序很快而且省时。