码迷,mamicode.com
首页 > 其他好文 > 详细

G - Who's in the Middle

时间:2016-07-22 21:08:12      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less. 
 

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow. 
 

Output

* Line 1: A single integer that is the median milk output. 
 

Sample Input

5
2
4
1
3
5
 

Sample Output

3

Hint

 INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3. 



AC代码:

sort函数:

#include<iostream>
#include<algorithm>
using namespace std;
 int a[1000001];
int main()
{
int n;

while(cin>>n)
{
    for(int i=0;i<n;i++)
        cin>>a[i];
    sort(a,a+n);
    cout<<a[n/2]<<endl;
}
return 0;
}

 冒泡法:

 
#include<iostream>
#include<cstdio>
int main()
{
  int n,a[20000];
  while(~scanf("%d",&n)&&n)
  {
      for(int i=0;i<n;i++)
      scanf("%d",&a[i]);
      for(int i=0;i<n-1;i++)
      {
          for(int j=i+1;j<n;j++)
          {
              if(a[i]>a[j])
              {
                  int m;
              m=a[i];
              a[i]=a[j];
              a[j]=m ;
              }
          }
      }
      printf("%d\n",a[n/2]);
  }
return 0;
}

 分析:水题,用sort函数排序很快而且省时。

 
 
 


















G - Who's in the Middle

标签:

原文地址:http://www.cnblogs.com/lbyj/p/5696881.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!