码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5745 la vie en rose

时间:2016-07-23 00:29:23      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:

这道题的官方题解是dp,但是可以暴力出来。改天再研究怎么dp。

暴力的时候,如果计算sum的时候,调用strlen函数会超时,可见这个函数并不是十分的好。以后能不用尽量不用。

 

La Vie en rose

Time Limit: 14000/7000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 861    Accepted Submission(s): 461


Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2...pm. So, he wants to generate as many as possible pattern strings from p using the following method:

1. select some indices i1,i2,...,ik such that 1i1<i2<...<ik<|p| and |ijij+1|>1 for all 1j<k.
2. swap pij and pij+1 for all 1jk.

Now, for a given a string s=s1s2...sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.
 

 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1n105,1mmin{5000,n}) -- the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.
 

 

Output
For each test case, output a binary string of length n. The i-th character is "1" if and only if the substring sisi+1...si+m1 is one of the generated patterns.
 

 

Sample Input
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

 

Sample Output
1010 1110 100100100
 

 

Author
zimpha
 

 

Source
 
技术分享
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int maxx=100005;
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,m;
        char s[maxx];
        char p[maxx];
        scanf("%d%d",&n,&m);
        scanf("%s",s);
        scanf("%s",p);
        int sump[maxx];
        int sums[maxx];
        sump[0]=sums[0]=0;
        for(int i=1;i<=n;i++){
            sums[i]=s[i-1]-a+sums[i-1];
        }
        for(int i=1;i<=m;i++){
            sump[i]=p[i-1]-a+sump[i-1];
        }
        int pis=sump[m];
        int shave=sums[m];
        for(int i=m;i<=n;i++){
            shave=sums[i]-sums[i-m];
           // cout<<"shave: "<<shave<<endl;
            if(pis==shave){
                int sta=i-m;
                int pos=sta;
                int flag=1;
                for(int j=0;pos<i;j++){
                    if(s[pos]==p[j]){
                        pos++;
                    }else{
                        if(pos+1<i&&s[pos+1]==p[j]&&s[pos]==p[j+1]){
                            pos+=2;
                            j++;
                        }else{
                            flag=0;
                            break;
                        }
                    }
                }
                if(flag){
                    printf("1");
                }else{
                    printf("0");
                }
            }else{
                printf("0");
            }
        }
        for(int i=m-1;i>0;i--){
            printf("0");
        }
        printf("\n");

    }
    return 0;
}
View Code

 

hdu 5745 la vie en rose

标签:

原文地址:http://www.cnblogs.com/superxuezhazha/p/5697505.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!