码迷,mamicode.com
首页 > 其他好文 > 详细

FatMouse' Trade hdu1009

时间:2016-07-23 22:52:30      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66570    Accepted Submission(s): 22635


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
康康准备了 M 斤的食物, 准备跟舍长交换哲学之宝 ♂
舍长有 N 个房间. 第 i 个房间有 J[i] 的 ♂ 需要 F[i] 斤的食物. 康康可以不换完整个房间的♂ ,
他可以用 F[i]* a% 的食物 换 J[i]* a% 的 ♂ 
现在给你一个实数 M 问你康康最多能获得多少的 ♂

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 

 

Sample Output
13.333 31.500
 

 

Author
CHEN, Yue
 
思路:1 struct 结构体存储数据,
        2 由“可以用 F[i]* a% 的食物 换 J[i]* a% 的 ♂ ”可知, F[i] / J[i] 越大, 康康从该房间换取的♂ 越多,
          故用sort函数按 F[i] / J[i]从大到小排序,
        3 康康的食物有限,所以进房间后可能换走所有的♂,也可能按    “F[i]* a% 的食物 换 J[i]* a% 的 ♂ ”的法则    换走部分的♂
           要先判断康康进去房间时的粮食与该房间的f[i]的大小。
 
代码如下:
 
#include<cstdio>
#include<algorithm>
using namespace std;
struct Huan
{
    double j,f;
    double c;
}huan[3005];
bool cmp( Huan a, Huan b)
{
        return a.c > b.c ;
}
int main()
{
    double m;
    int n,t;
    while( scanf("%lf%d", &m, &n)!=EOF && ( m!=-1 || n!=-1 ) )
    {
        int i, j, k;
        double sum=0; 
        for( i=0; i<n; i++)
        {
            scanf("%lf%lf", &huan[i].j, &huan[i].f);
            huan[i].c = huan[i].j / huan[i].f;        }
        sort(huan, huan+n, cmp);//按f从小到大排序 
        for( i=0; i<n; i++)
        {
            if( m >= huan[i].f )//全盘换了 
            {    sum += huan[i].j;    m -=  huan[i].f;    }   
            else//大米的数量不足全盘换 
            {   sum +=  m*huan[i].c ;    break;    }      
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

FatMouse' Trade hdu1009

标签:

原文地址:http://www.cnblogs.com/123tang/p/5699561.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!