码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1021(模运算)

时间:2016-07-24 14:59:59      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52548    Accepted Submission(s): 24840


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0
1
2
3
4
5
 

 

Sample Output
no
no
yes
no
no
no
 
思路:打表函数每项模3的值,若结果为0则可以被3整除。
#include <cstdio>
using namespace std;
const int MAXN=1000005;
int f[MAXN];
int main()
{
    f[0]=7%3;
    f[1]=11%3;
    for(int i=2;i<1000000;i++)
    {
        f[i]=(f[i-1]+f[i-2])%3;
    }
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(f[n]==0)
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
    return 0;
}

 

HDU1021(模运算)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5700759.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!