码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1548 A strange lift【不错的最短路,spfa】

时间:2016-07-29 15:46:56      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:


A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21281    Accepted Submission(s): 7786


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you‘ll go up to the 4 th floor,and if you press the button "DOWN", the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2 th floor isn‘t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can‘t reach floor B,printf "-1".
 

Sample Input
5 1 5 3 3 1 2 5 0
 

Sample Output
3
    原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1548

题目大意:

n代表楼梯层数,A代表起始位置,B代表终止位置,接下来有n个数,代表到达每一层后,可以选择按      按钮“UP”,“DOWN” ,代表执行此操作后电梯可上升或下降的层数(注意:是变化的层数,且合法),问你至少需要按多少次按钮?

思路:

此题看起来有一点复杂,但转化一下就变得简单了。以每一层及其可到达的楼层为顶点建立有向图,并把其权值设为1,此问题即可住转化为从起点到终点的最短路径。

我用Dijkstra算法WA,难道有负权?此题也有人用BFS解决的。

sofa算法AC代码:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int INF=0x3f3f3f3f;
int a[205][205];
int dis[205];
bool vis[205];
int s,t,n;
void spfa()
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=INF;
        vis[i]=false;
    }
    dis[s]=0;
    vis[s]=true;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int p=q.front();
        q.pop();
        vis[p]=true;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]>dis[p]+a[p][i])
            {
                dis[i]=dis[p]+a[p][i];
                if(!vis[i])
                {
                    vis[i]=true;
                    q.push(i);
                }
            }
        }
    }
}
int main()
{
    while(cin>>n,n)
    {
        cin>>s>>t;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
                if(i==j)a[i][j]=0;
                else a[i][j]=INF;
        }
        int x;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(i-x>=1) a[i][i-x]=1;
            if(i+x<=n) a[i][i+x]=1;
        }
        spfa();
        if(dis[t]>=INF)
            cout<<"-1"<<endl;
        else
            cout<<dis[t]<<endl;
    }
    return 0;
}



HDU 1548 A strange lift【不错的最短路,spfa】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52056515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!