码迷,mamicode.com
首页 > 其他好文 > 详细

Frogger

时间:2016-07-29 21:23:48      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意:青蛙从A点跳到B点的所有路径中最长边的最小值(也就是哪一条通路里面的最长边相对其他通路中的最长边最小),也可以说成是最小生成树里
面的最大边。输出此最小值即可。

思路:题目就是求最小生成树中的最大边,即prim算法的灵活运用。就是在求最小生成树的过程当中,不断地去比较最小生成树的各边,当达到B点时就结
束查找

代码如下:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double a[200][2];
double lowcost[200],closet[200];
double map[200][200];
int main()
{
    int n;
    int k=1;
    while(cin>>n,n)
    {
        int i,j;
        for (i = 0 ;i < n ; i++ )
            cin>>a[i][0]>>a[i][1];
        memset(lowcost,0,sizeof(lowcost));
        for ( i = 0 ; i < n ; i ++ )
        {
            for ( j = 0 ; j < n ; j ++ )
            {
                map[i][j]=1.0*sqrt(pow(1.0*abs(a[i][0]-a[j][0]),2)+pow(1.0*abs(a[i][1]-a[j][1]),2));
            }
        }
        double ans=0.0;
        for ( i = 0 ; i< n ; i++ )//先以点A为起点,将各点到A点的距离记录下来。
        {
            lowcost[i]=map[0][i];
            closet[i]=0;
        }

        for ( i = 0 ; i < n - 1 ; i ++ )
        {
            double mindis=1.0*(1<<20);
            int minone;
            for ( j = 0 ; j < n ; j ++ )
            {
                if(lowcost[j]&&mindis>lowcost[j]) //找到最短的边作为最小生成树的一部分
                {
                    mindis=lowcost[j];
                    minone=j;
                }
            }
            if(ans<mindis)
                ans=mindis;
            lowcost[minone]=0.0;
            if(minone==1) //到达B点即可结束,输出ans
                break;
            for ( j = 0 ; j < n ; j ++ )
            {
                if(map[j][minone]<lowcost[j]) //用来更新数组,保留值较小的
                { lowcost[j]=map[j][minone];
                    closet[j]=minone;
                }
            }
        }
        cout<<"Scenario #"<<k<<endl;
        printf("Frog Distance = %.3f\n\n",ans);
        k++;
    }
    return 0;
}

Frogger

标签:

原文地址:http://www.cnblogs.com/441179572qqcom/p/5719498.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!