码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5768Lucky7

时间:2016-07-30 20:59:39      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Lucky7

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 933    Accepted Submission(s): 345


Problem Description
When ?? was born, seven crows flew in and stopped beside him. In its childhood, ?? had been unfortunately fall into the sea. While it was dying, seven dolphins arched its body and sent it back to the shore. It is said that ?? used to surrounded by 7 candles when he faced a extremely difficult problem, and always solve it in seven minutes. 
?? once wrote an autobiography, which mentioned something about himself. In his book, it said seven is his favorite number and he thinks that a number can be divisible by seven can bring him good luck. On the other hand, ?? abhors some other prime numbers and thinks a number x divided by pi which is one of these prime numbers with a given remainder ai will bring him bad luck. In this case, many of his lucky numbers are sullied because they can be divisible by 7 and also has a remainder of ai when it is divided by the prime number pi.
Now give you a pair of x and y, and N pairs of ai and pi, please find out how many numbers between x and y can bring ?? good luck.
 

 

Input
On the first line there is an integer T(T≤20) representing the number of test cases.
Each test case starts with three integers three intergers n, x, y(0<=n<=15,0<x<y<1018) on a line where n is the number of pirmes. 
Following on n lines each contains two integers pi, ai where pi is the pirme and ?? abhors the numbers have a remainder of ai when they are divided by pi. 
It is guranteed that all the pi are distinct and pi!=7. 
It is also guaranteed that p1*p2*…*pn<=1018 and 0<ai<pi<=105for every i∈(1…n).
 

 

Output
For each test case, first output "Case #x: ",x=1,2,3...., then output the correct answer on a line.
 

 

Sample Input
2
2 1 100
3 2
5 3
0 1 100
 
Sample Output
Case #1: 7 Case #2: 14
Hint
For Case 1: 7,21,42,49,70,84,91 are the seven numbers. For Case2: 7,14,21,28,35,42,49,56,63,70,77,84,91,98 are the fourteen numbers.

 

好题啊  学到了很多东西...

首先 俄罗斯乘法用于大数取模。中国剩余定理解同模方程组。记住这个解不是唯一的...

容斥原理解决 统计问题

/* ***********************************************
Author        :guanjun
Created Time  :2016/7/30 13:10:44
File Name     :hdu5768.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;

ll a[20],m[20];
void ex_gcd(ll a,ll b,ll &d,ll &x,ll &y){
    if(!b){d=a;x=1LL;y=0LL;}
    else {ex_gcd(b,a%b,d,y,x);y-=x*(a/b);}
}
ll mult(ll a,ll k,ll m){
    ll res=0;
    while(k){
        if(k&1LL)res=(res+a)%m;
        k>>=1;
        a=(a<<1)%m;
    }
    return res;
}
ll china(int n,ll *a,ll *m){
    ll M=1,d,y,x=0;
    for(int i=0;i<n;i++)M*=m[i];
    for(int i=0;i<n;i++){
        ll w=M/m[i];
        ex_gcd(m[i],w,d,d,y);
        x=(x+mult(y,mult(w,a[i],M),M))%M;
    }
    return (x+M)%M;
}
ll p[20],yu[20];
int n;
ll get_ans(ll x){
    if(x==0)return 0;
    ll ans=0;
    int st=(1<<n);
    for(int i=1;i<st;i++){
        int cnt=0;
        ll cur=1;
        m[cnt]=7;a[cnt]=0;
        cur*=7;cnt++;
        for(int j=0;j<n;j++){
            if(i&(1<<j)){
                m[cnt]=p[j];
                a[cnt]=yu[j];
                cnt++;
                cur*=p[j];
            }
        }
        ll tmp=china(cnt,a,m);
        if(tmp>x)continue;
        if(cnt&1)ans+=(x-tmp)/cur+1;
        else ans-=(x-tmp)/cur+1;
    }
    //cout<<ans<<endl;
    return ans+x/7;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int T,t;
    ll l,r;
    cin>>T;
    for(int t=1;t<=T;t++){
        scanf("%d %I64d %I64d",&n,&l,&r);
        for(int i=0;i<n;i++)
            scanf("%I64d %I64d",&p[i],&yu[i]);
        printf("Case #%d: %I64d\n",t,get_ans(r)-get_ans(l-1));
    }
    return 0;
}

 

HDU5768Lucky7

标签:

原文地址:http://www.cnblogs.com/pk28/p/5721607.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!