码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5763 Another Meaning 哈希+dp

时间:2016-07-30 21:10:23      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Another Meaning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 917    Accepted Submission(s): 434


Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

 

Sample Input
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
 

 

Sample Output
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.

题意:给你一个主串一个子串,然后主串中匹配到子串就可以把匹配部分改为*(也可以不改),问主串有多少钟不同的样子;

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
typedef  long long  ll;
typedef unsigned long long ull;
#define MM(a,b) memset(a,b,sizeof(a));
#define inf 0x7f7f7f7f
#define FOR(i,n) for(int i=1;i<=n;i++)
#define CT continue;
#define PF printf
#define SC scanf
const int mod=1000000007;
const int N=1e5+10;

int la,lb;
ll dp[N];
char a[N],b[N];
ull ha[N],hb;
ull seed=13331;

void init(){
   hb=0;
   for(int i=0;i<lb;i++)
       hb=hb*seed+b[i];
   ull base=1;
   for(int i=1;i<=lb-1;i++) base*=seed;
   ha[0]=a[0];
   for(int i=1;i<=lb-1;i++)
       ha[i]=ha[i-1]*seed+a[i];
   for(int i=lb;i<la;i++)
       ha[i]=(ha[i-1]-a[i-1-(lb-1)]*base)*seed+a[i];
}

int main()
{
    int cas,kk=0;
    scanf("%d",&cas);
    while(cas--){
        scanf("%s",a);
        scanf("%s",b);
        la=strlen(a);lb=strlen(b);
        if(la<lb) {printf("Case #%d: 1\n",++kk);CT;}
        init();
        for(int i=0;i<=lb-1;i++) dp[i]=1;
        if(ha[lb-1]==hb) dp[lb-1]=2;
        for(int i=lb;i<la;i++){
           dp[i]=dp[i-1]%mod;
           if(ha[i]==hb) dp[i]=(dp[i]+dp[i-lb])%mod;
        }
        printf("Case #%d: %lld\n",++kk,dp[la-1]%mod);
    }
    return 0;
}

  分析:错误点:

1.BKDRhash不太熟练,只会原来的最后输出&的形式,导致最后计算复杂;

改进:BKDRhash的形式:pre*seed+a[i],seed为13331之类的大素数,pre为i以前的哈希值;

a[i]就是字符

2,没有想到dp,当前下标i的话,dp[i]的数值,如果当前i并未匹配到子串,dp[i]=dp[i-1];

如果匹配到子串,dp[i]=dp[i-1]+dp[i-lb];

hdu 5763 Another Meaning 哈希+dp

标签:

原文地址:http://www.cnblogs.com/smilesundream/p/5721687.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!