码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1217 Arbitrage 【最短路,map+spfa】

时间:2016-07-30 22:43:28      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:


Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6985    Accepted Submission(s): 3212


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
Case 1: Yes Case 2: No
 

Source


题目大意:

给了你集中货币,及其之间的汇率,问你是否存在某种货币经过与其他货币的进行一个回路的兑换后能否获利。

一看就是最短路的问题,关键是初始值,改成最‘大’路就可以了,好多人多都用Floyd算,spfa算法那么好,怎么不用?对于顶点的话,用map就好了。

spfa算法AC代码:


#include <iostream>
#include <cstdio>
#include <map>
#include <queue>
using namespace std;
double a[35][35];
double dis[35];
bool vis[35];
int n;

bool spfa(int s)
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=0;
        vis[i]=false;
    }
    dis[s]=1.0;
    vis[s]=true;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int p=q.front();
        q.pop();
        vis[p]=false;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]<dis[p]*a[p][i])
            {
                dis[i]=dis[p]*a[p][i];
                if(!vis[i])
                {
                    vis[i]=true;
                    q.push(i);
                }
                if(dis[s]>1.0)
                    return true;
            }
        }
    }
    return false;
}

int main()
{
    int kase=0;
    map<string,double>mapp;
    char s1[35],s2[35];
    while(cin>>n,n)
    {
        mapp.clear();
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                if(i==j) a[i][j]=1.0;
                else a[i][j]=0;
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%s",s1);
            mapp[s1]=i;
        }
        int t;
        cin>>t;
        double d;
        while(t--)
        {
            scanf("%s%lf%s",s1,&d,s2);
                int x=mapp[s1];
                int y=mapp[s2];
                a[x][y]=d;
        }
        cout<<"Case "<<++kase<<": ";
        bool flag=true;;
        for(int i=1;i<=n;i++)
        {
            if(spfa(i))
            {
                flag=false;
                cout<<"Yes"<<endl;
                break;
            }
        }
        if(flag)
            cout<<"No"<<endl;
    }
    return 0;
}



HDU 1217 Arbitrage 【最短路,map+spfa】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52075154

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!