标签:
Description
Input
Output
Sample Input
2 1 2
Sample Output
2 8
分析:本题是一个数学题,题目的关键是找出递推公式,a[i]=a[i-1]+6*(i-1);
问题:结果对的(不存在漏解什么的),一直提交不对,一开始用C++提交就是过不了,然后我将数组开大,过了;于是我又用G++提交了一遍不需要开大数组也能过,真的是无语了。。。。。。。。。。。
AC代码:
#include<iostream>
using namespace std;
long long a[10000];
int main()
{
int n;
a[1]=2;
for(int i=2;i<=10000;i++)
a[i]=a[i-1]+6*(i-1);
cin>>n;
while(n--)
{
int m;
cin>>m;
cout<<a[m]<<endl;
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/lbyj/p/5723995.html